Saint Joseph's University IT Status - UC Telephone Systems Outage – Incident details
Horizon View experiencing partial outage
IT Scheduled Maintenance Calendar
UC Telephone Systems Outage
Resolved
Major outage
Started 8 months agoLasted about 1 hour
Affected
Network / TV / Phones
Major outage from 1:13 PM to 2:25 PM
Phones
Major outage from 1:13 PM to 2:25 PM
Updates
Resolved
Resolved
The Telephone systems issue was resolved by 8:45 this morning. We have concluded testing to confirm comprehensive resoluion. Telephone services at UC are now fully operational and systems appear to be stable.
Investigating
Investigating
The University City location phones servers went off line this morning and are currently non-operational. We are currently investigating this incident. All phones and phones lines at UC are affected.