Saint Joseph's University IT Status - Guest Registration at University City Issues – Incident details

Horizon View experiencing partial outage

IT Scheduled Maintenance Calendar

Guest Registration at University City Issues

Resolved
Operational
Started 4 months agoLasted 29 minutes

Affected

Network / TV / Phones

Operational from 2:06 PM to 2:35 PM

WiFi

Operational from 2:06 PM to 2:35 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We are currently investigating an incident where the Guest registration email at University City is not being sent