Saint Joseph's University IT Status - PA College Portal Outage – Incident details

All systems operational

IT Scheduled Maintenance Calendar

PA College Portal Outage

Resolved
Operational
Started 3 months agoLasted about 6 hours

Affected

Lancaster Location

Major outage from 3:13 PM to 9:15 PM

PA College Portal

Major outage from 3:13 PM to 9:15 PM

Updates
  • Resolved
    Resolved

    Issue is now resolved. Postmortem report is forthcoming.

  • Identified
    Identified

    The issue has been identified and remediation is underway.

  • Investigating
    Investigating

    The Lancaster Location's legacy portal - my.pacollege.edu - is currently unavailable. IT is working to triage and resolve this issue.