Saint Joseph's University IT Status - TeamDynamix - Performance Degradation – Incident details

WiFi - UC under maintenance

IT Scheduled Maintenance Calendar

TeamDynamix - Performance Degradation

Resolved
Degraded performance
Started 4 months agoLasted about 8 hours

Affected

Collaboration and Enterprise Services

Degraded performance from 2:48 PM to 10:42 PM

TeamDynamix

Degraded performance from 2:48 PM to 10:42 PM

Updates
  • Resolved
    Resolved

    Incident resolved

    TeamDynamix resolved the issue that was causing degraded performance in Work Management, and full service has now been restored.

  • Identified
    Identified

    We are waiting for TeamDynamix to fix this issue. For more info, please check https://status.teamdynamix.com/