Saint Joseph's University IT Status - Verizon wireless network outage – Incident details

All systems operational

IT Scheduled Maintenance Calendar

Verizon wireless network outage

Resolved
Major outage
Started 2 days agoLasted about 19 hours
Updates
  • Resolved
    Resolved

    Verizon has restored all services.

  • Monitoring
    Monitoring

    Verizon is currently experiencing a network outage affecting voice and data services for some customers. We will update as we learn more information from the provider.