Saint Joseph's University IT Status - Horizon View virtual desktops, wired and wireless LAN at Lancaster unavailable – Incident details

IT Scheduled Maintenance Calendar

Horizon View virtual desktops, wired and wireless LAN at Lancaster unavailable

Resolved
Major outage
Started 2 days agoLasted 1 day

Affected

Network / TV / Phones

Major outage from 1:06 AM to 4:25 PM

Network / TV / Phones - Lancaster Location

Major outage from 1:06 AM to 4:25 PM

WiFi - LL

Major outage from 1:06 AM to 4:25 PM

Phones - LL

Major outage from 1:06 AM to 4:25 PM

Wired Network Connectivity - LL

Major outage from 1:06 AM to 4:25 PM

Voicemail - LL

Major outage from 1:06 AM to 4:25 PM

Updates
  • Resolved
    Resolved

    The power outage at Lancaster has been resolved. All IT systems and services for Lancaster are fully online and operational.

  • Identified
    Identified

    The Lancaster location is currently experiencing power and IT network issues due to a regional power outage. This affects the Horizon virtual desktop environment as well as on-campus network connectivity.