All systems operational

IT Scheduled Maintenance Calendar

Merion Hall 1st floor - wired and wireless network unavaialble

Resolved
Partial outage
Started 6 months ago Lasted about 1 hour

Affected

Network / TV / Phones
Voicemail
Intercampus Network Connectivity
Wired Network Connectivity
WiFi
Phones
Updates
  • Resolved
    Resolved

    This incident has been resolved. A battery backup device had failed and has been bypassed, restoring power to the network equipment.

  • Investigating
    Investigating

    We are currently investigating this incident.