All systems operational

IT Scheduled Maintenance Calendar

Gmail messages delayed

Resolved
Degraded performance
Started 5 months ago Lasted about 3 hours

Affected

Collaboration and Enterprise Services
Google
Third Party: Google Workspace → Gmail
Updates
  • Resolved
    Resolved

    This incident has now been resolved per Google:

    The issue with email delays was mitigated for the majority of affected users at 11:45 US/Pacific.

    A few users may have observed delays until the full mitigation was done at 13:15 US/Pacific.

    We will publish an analysis of this incident once we have completed our internal investigation.

    We thank you for your patience while we worked on resolving the issue.

  • Monitoring
    Monitoring

    Google has reported an issue with Google Workspace. Sending messages from Gmail may be delayed. For immediate updates, please refer to Google's status dashboard located here:

    https://www.google.com/appsstatus/dashboard/