Saint Joseph's University IT Status - Performance issues for The Nest, sju.edu, and other hosted websites – Incident details

All systems operational

IT Scheduled Maintenance Calendar

Performance issues for The Nest, sju.edu, and other hosted websites

Resolved
Degraded performance
Started 4 months agoLasted about 2 hours

Affected

Websites

Degraded performance from 1:32 PM to 3:17 PM

SJU Main Website

Degraded performance from 1:32 PM to 3:17 PM

The Nest

Degraded performance from 1:32 PM to 3:17 PM

SJU Sites

Degraded performance from 1:32 PM to 3:17 PM

SJU Alumni and Kinney Websites

Degraded performance from 1:32 PM to 3:17 PM

Updates
  • Resolved
    Resolved

    The issue affecting performance for our hosted websites has been resolved. We will continue to work with the vendor on root cause analysis and postmortem document.

  • Investigating
    Investigating

    We are currently investigating an issue with our hosted web provider. Certain hosted websites such as The Nest, the main sju.edu website, and various other sites (announcements, directory) may see sporadic slowness.