Saint Joseph's University IT Status - Workday is unavailable. – Incident details

All systems operational

IT Scheduled Maintenance Calendar

Workday is unavailable.

Resolved
Operational
Started 2 months agoLasted about 1 hour

Affected

Banner / Workday

Major outage from 7:14 PM to 8:21 PM

Workday

Major outage from 7:14 PM to 8:21 PM

Updates
  • Resolved
    Resolved

    Workday has resolved the issue and is fully operational.

  • Investigating
    Investigating

    Workday has acknowledged the outage. Below is the most recent update:

    Please be advised that beginning at approximately 11:20 AM PT, we began experiencing performance issues in all  WD1, WD2, WD3, and WD5 Data Centers. 

    We appreciate your patience as we actively work to identify the root cause and implement a solution. We will provide another update by 12:30 PM PT.