Saint Joseph's University IT Status - Workday landing page error – Incident details

IT Scheduled Maintenance Calendar

Workday landing page error

Resolved
Degraded performance
Started about 11 hours agoLasted about 8 hours

Affected

Banner / Workday

Degraded performance from 12:51 PM to 9:15 PM

Workday

Degraded performance from 12:51 PM to 9:15 PM

Updates
  • Resolved
    UTC
    Resolved

    Workday has resolved all issues and is fully operational.

  • Monitoring
    UTC
    Monitoring

    Workday has implemented fixes and continues to monitor for any continued issues.

  • Investigating
    UTC
    Investigating

    The landing page when logging into Workday is unavailable. Navigation and search continues to work properly. The issue has been reported to Workday.

    Latest update from Workday:

    The main issue is actively affecting the data center, and our teams are treating this with the highest priority. Restoring core operations is our main focus, and we are dedicating all necessary resources to resolve it as quickly as possible. Thank you for your continued patience.