Saint Joseph's University IT Status - Windows Devices - Performance Issues – Incident details

All systems operational

IT Scheduled Maintenance Calendar

Windows Devices - Performance Issues

Resolved
Operational
Started 8 days agoLasted less than a minute
Updates
  • Update
    Update

    The issue affecting some SJU-issued Windows devices was identified yesterday early afternoon and a fix was implemented.

  • Resolved
    Resolved

    The Office of Information Technology (OIT) is aware of an issue affecting a subset of SJU-provided Windows devices. Users affected by this issue may see applications freeze, become non-responsive, experience Zoom crashing, the device overheating, and other behaviors that cause slow performance. OIT is actively investigating this issue and working on a fix.