Saint Joseph's University IT Status - Wireless in Sister Thea Bowman Hall – Incident details

WiFi - HH experiencing degraded performance

IT Scheduled Maintenance Calendar

Wireless in Sister Thea Bowman Hall

Monitoring
Degraded performance
Started 7 days ago

Affected

Network / TV / Phones

Degraded performance from 3:07 AM to 12:00 AM

Network / TV / Phones - Hawk Hill

Degraded performance from 3:07 AM to 12:00 AM

WiFi - HH

Degraded performance from 3:07 AM to 12:00 AM

Updates
  • Monitoring
    Monitoring

    We've made several changes to improve Wi-Fi availability in Sr. Thea Bowman, but performance issues are still being observed. We are actively monitoring. Further review and optimization are scheduled.

  • Investigating
    Investigating

    We are aware of intermittent wireless connectivity issues throughout the Sister Thea Bowman Residence Hall. Our team is currently investigating the issue and working on a resolution. We appreciate your patience.